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1. Introduction

Genuineness and integrity of PDF documents win increasingly in meaning. PDF (Portable
Document format) is a common, open format for digital documents. Digital signatures become
more and more important, because PDF files are very simply to be changed.  With the Aloaha
PDF Signator this widespread file format can be also used certainly for official business relations,
e.g., for electronic calculation position, transmission by offers or for digital signing of contracts.
 
With the Aloaha PDF Signator you can open PDF documents, read and sign.
Already existing PDF files can be signed. No special preparations or signature fields are
necessary. 
The digital signature of a PDF file can be checked and indicated by the receiver with a PDF-Viewer
(Acrobat Reader). You do not have to instal special software for this checking process. 
The Aloaha PDF Signator enables to stock PDF documents with RFC 3161 compatible time
stamps. 
After a defined time digital certificates lose their validity. You should not accept an invalid
certificate to sign documents. It is not necessary to keep an electronically signed document longer
than the certificate is valid. As an example contracts or also electronically signed calculations are
to be mentioned. If a contract with a time stamp of a time stamp service (TSA) became stock, the
signature can be longer valid than the certificate. 

· With the PDF Signator it is possible to sign PDF documents electronically without having to buy
a full version from Adobe Acrobat ® or Adobe Document to server for reader Extensions ® what
contributes to the operating expenses lowering.

· By authentification of the origin of a PDF document can be made sure that a document of a
dependable source comes which vouches for the equality of the document and genuineness of
the signatory.

· Any number of people can countersign the same PDF document. The information of every
signatory is maintained and proved by every opening of a file.

· WebDAV
· Secure PIN entry
· RemoteControl API 

Interoperability
The signatures which were generated with the Aloaha PDF Signator can be also checked with the
Adobe Reader ® and Acrobat.

The Aloaha PDF Signator is completely PKI neutrally and works with PKI components of every
provider. (This contains CAs, certificates, CRLs, response television stations OCSP, SmartCards
etc.)
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2. Usage
You simply open a file or a form with the Aloaha Signator and fill the form fields, or sign the file.

Note: You can open a Toolbar via View > Toolbar or CTRL + T !

To save a file and overwrite an old one you can click with the help of the toolbar on the disk icon.
The system asks you if you want to overwrite the existing file.

If you liked to save only the form data as a XML file go forward as shown below:

Click on File > Save as ...

... and save the form data as file type xml.

Note: If you open this XML file with Aloaha the program automatically opens the
corresponding PDF and enters the XML data!
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3. Installation

System requirements
Installation
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3.1 System requirements

The following operating systems are supported by the Aloaha PDF Signator:

· Windows 2000, Windows 2003, Windows 2008, Windows XP, Windows Vista, Windows 7
· No Adobe Reader necessary!
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3.2 Installation

Before you start with the installation of the software, you should have installed a suitable Smart
card with electronic chip and a card reader. Software Certificates are also supported. You are able
to create free test certificates to yourselves on http://pki.aloaha.com .

The Aloaha PDF Signator is sent to you by e-mail after Internet order with licence key. To install
the Aloaha PDF Signator, launch the setup program.

Before you start setup you certainly put all Windows applications closed and you are logged on as
an administrator.

To install the Aloaha PDF Signator download the installation package from 
http://www.aloaha.com/download/aloaha_saver.zip

The installation package contains a file 'aloaha_signator.exe'. Please start that file with a double
click.
After you choose your language the setup will start.

Setup will ask you for the installation folder before it begins to install the product. 

http://pki.aloaha.com
http://www.aloaha.com/download/aloaha_saver.zip
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For using a different folder, click the Browse button and select the folder you want to install to.

Note: It is suggested to install all Aloaha products in the same directory.

If setup has installed successful the application you have to click the finish button.

Now you can use the Aloaha PDF Signator. In your top menu under programmes / Aloaha you will
find a shortcut for opening the program.
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4. Configuration

File
View
Print
Settings
Page
Info
Help
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4.1 File

To be able to save or to open PDF documents click you on the menu item "File".

Alternatively you can "open, sign or save" documents about the Toolbar (show with CTRL + T).
If you work with the toolbar, you will have advanced memory options.
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4.1.1 Open

Should you open an encrypted document with a digital ID, it is necessary, that your digital ID is
correctly installed. 
If necessary contact the author of the document to receive the public key.

If there is no public key for the receiver of the document available, it cannot be opened.

4.1.2 Save / Save as

If you liked to save a signed PDF file, select "Save" or "save as".

You also reach with the right mouse button the menu "File > Save".
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4.1.3 Upload to

If you liked to upload documents on a WebDAV server (as for example Microsoft Exchange or
SharePoint server), select the command "Upload to".

After you have entered the filename of the file to be uploaded, you are requested,

to enter the username and the matching password, so that the file can be uploaded.
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4.1.4 Save read only

With the option "Save read only", it is no more possible to change the document afterwards.

right mouse button

After the storage process it is not possible any more to change dropdown fields.
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4.1.5 Sign and Save

With the command "sign and save" the document is sealed and saved as a PDF document.

Before saving you where asked to select a file store and to stock the document with a filename.
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Confirm the certificate to be used, while you click on the field with the green hook.

Now you are requested to the enter the PIN associated to the certificate.
Enter the suitable PIN and confirm afterwards the input.

After the signature process the document can be found in the selected memory store.
Tip: Embedded files are also signed.
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4.1.6 Exit

With the command "Exit" the application is closed. 
Before you should have saved the documents.If your documents are not saved, a security query
appears.
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4.2 View

In the menu "View" following options stand at possession:

· DPI
· Best Size
· Toolbar
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4.2.1 DPI

DPI is synonymous with “dots per inch”. In the general usage the resolution of a printing file is
meant. 
In the printing process the print format is converted into small dots, is printed in halftone so. This
halftoning is hardly visible to the viewer.

The resolution can be adjusted accordingly of the desired print format in the menu View > DPI.

4.2.2 Best Size

In the mode "best size" fits Aloaha the screen window optimally to the available system resources.

4.2.3 Toolbar

You can call the toolbar, while you

· select the keyboard shortcut CTRL + T
· select View > Toolbar in the menu.

In the tool bar different operations, how

· Documents open, sign and save
· directly save
· print document
· Settings for the digital signature
· sign document electronically and save

are able to be carried out.
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4.3 Print

You have different possibilities to reach to the printing menu.
· Select the menu item "printing" about the object menu

· CTRL + T > Dropdown field besides the printer

4.3.1 Use Adobe Engine

With "Use Adobe engine" you inform the program to use the Adobe engine instead of the own
printing engine. In some cases it can be an advantage.

Moreover the Adobe Reader must be installed, because he is used for printing.
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4.3.2 Settings

You can use the tool bar (CTRL + T) to reach the printing menu.
Here you select print settings for your document.

In the menu item "advanced settings" you can fix which of the available printers in the system
should be used to print out your PDF documents.
Should the printer dispose several possibilities of the paper feed, you can select this in the menu
item "Paper Tray".

If you activate the field "Eco", your document is printed in the toner / ink saving mode.

If you activate the field "Duplex", it is printed at the same time or in two steps of front and back of
the media.

If you select the command "Print", the document is printed on the default printer.

If you select "print to", you can select on which printer the document should be printed.

If you select "print current page", the currently indicated page is printed to the default printer.

If you select "print current page to", you can select on which printer the current page should be
printed.
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4.3.3 Print

If you select the menu item "print", Aloaha prints all documents to the default printer.
Alternatively you can also fix a printer of your choice for the printouts.

4.3.4 Print to default printer

If you select the menu item "print to default printer", Aloaha prints all documents to the default
printer without other set possibilities.
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4.4 Settings

In the menu settings you have the possibility to configure settings for:

· Borders
· Digital Signatures
· Language

4.4.1 Borders

If you activate the setting Border, form fields are indicated bordered.

View without Borders:

View with Borders:
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4.4.2 Digital Signature

If you go to menu>settings>digital signatures the following window will open. Here you can
make modifications of certificate settings.

1. Certificate source
Here you can select between the different certificates which you would like to use for signing your
PDF files: 

•
Computer certificates
All certificates which are associated in the Windows certificate store to the computer are
indicated in the certificate store list.

•
User certificates (Standard) 
All certificates which are associated in the Windows certificate store to the user are indicated in
the certificate store list. This is the suggested setting!

•
Active Directory certificates
All released certificates which are available in the Active Directory are indicated in the
certificate list. 

•
Signature card (e-ID) 
All connected card readers are indicated in the certificate list.
This is the suggested setting for nativ supported cards . 
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2. Certificate Filter
Here you can filter the certificate list of the shown certificates after special certificate attributes. If
signature card (e-ID) is selected, it can be choosen between SHA-1 and SHA-256!
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3. Settings for the time stamp 
If you click on the watch icon a new window opens:

Here you can customise the settings for the integrated RFC 3161 compatible time stamp client.

In the upper field you select the time stamp server. If the filed is empty, you can download the list
of the possible time stamp servers from the Aloaha Website.

If you select http://AloahaTimestamper, the PDF Signator integrated TimeStamp server is used.
On this occasion, the local system time is taken as a basis for the time stamp.

In user data you configure the access data to the time stamp service. 

If you still have no access to a time stamp service, you can use test-wise our service https://tsa.
aloaha.com/tsa.asp 

Please note: Many time stamp services are not RFC compliant. That is the reason why the Adobe
reader does not show the time stamp!

https://tsa.aloaha.com/tsa.asp
https://tsa.aloaha.com/tsa.asp
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4. Certificate select
This menu depends on the certificate source. If you select "user certificate" you will receive a list of
all "user certificates" on your PC. You can choose one of them.
If you select the SmartCard (e-ID) option, all installed SmartCard readers appear in this menu. The
Aloaha PDF Saver recognises automatically the Smart-Card inserted in the card reader and can
read the certificates of supported cards.
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5. Purpose of the signature
Here you can select which signature should be used automatically: 

• I am the author of this document 

• I sign this document

• I agree to this document

• I have seen this document

• I have got this document

Note: You can enter of course own text!

The suitable text appears by checking of the document!
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6. Signature appearance

By the possibility of the multiple signature other users can add comments.

Activate picture signature

If this option is selected a picture (as shown) is used in the PDF document. If you select the
signature picture you can load own image files. The picture must be in the format JPG then it is
seated as a picture into the PDF document. This is not the digital signature, but a tip for the
receiver of the document. By use of a picture as a signature appearance you can select
"incremental signature required". The signature is attached to the document and allows at any time
to recover the original.

Activate text signature

If this option is selected the text entered in the filed is used.

7. Position of the signature
With a click on the button "X Y" a position dialog appears

In the fields you give the position of the signature. On this occasion, it is calculated in % of the
page size.
Alternatively you can determine the position with the mouse.
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4.4.3 Language

Should you need another Userlanguage than the currently used, you can move this here.
After occurred conversion the program requires a restart, so that the updates become effective.

Currently available languages:
· German
· English
· Italian
· Dutch
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4.5 Page

Should your PDF document exist of several pages, you have the possibility with 

· F12-Key > to scroll one page forward
· F11-Key > to scroll one page backward
· CTRL + E > to jump at the end of the document
· the scrollbar at the lower end > to move in the document

4.6 Info

In the info area you find information about licensing.

In this document you see in the system found licence informations.
You can save own licences, while you enter a valid key and confirm the operation.
You get licences of Aloaha software from us by e-mail.

4.7 Help

You reach the Online Help about the F1 key or the Online Forum about the keys CTRL + F1.
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5. Sign digitally

PDF files electronically sign

With the Aloaha PDF Signator you can sign PDF files digitally. An electronic signature is supported
after the default of the signature law (SigG) of the Federal Republic of Germany.

Legal electronic calculations can be created.

Calculations which are transmitted by fax or e-mail and/or are provided to download from the
Internet (e.g., as a PDF document) and no "certified electronic signature" carry, display no
calculation for the purposes of the section 14 to paragraph 3 sales tax law.

From Aloaha PDF Signator created digital signatures are embedded in the PDF document and can
be checked with the Acrobat Reader up from version 6.

Digital Signature

A digital signature for the purposes of the law is „a seal generated with a private signature key to
digital data which with the help of an accompanying public key, with a signature key certificate of a
certification authority stock is, the owner of the signature key and the unadulterated quality of the
data reveals“ (SigG.).

With the development of the digital signature the destination was traced to develop one of the
personal signature equivalent signature method with which on electronic way data can be signed.

The main problem by transmission of electronic data is the manipulability. The problem could be
eliminated only by electronic signature, because an unnoticed manipulation of data is no more
possible.

Requirement is that the electronic signature is connected like a handwritten signature inseparably
with the respective document. It can be seen by everybody, but only be changed by the signer
itself. The signer can be identified and the signature makes every possible manipulation, like
additional pranks or changing text passages, immediately recognizable.

By the certificate check can be proved that the signature was not faked and the certificate owner is
real. except his name no personal data is revealed.

Legal regulations

Definitions of different kinds of the digital signature are found in the signature law (SigG) and in the
order to the signature law (SigV). In it demands for the electronic signatures are as well displayed
as Certification Service Provider (ZDA) were defined.

It is distinguished in easy, advanced and certified digital signatures. Every signature stands for a
certain quality level. The higher valued the signature, the more meaning she has for the legal
relations, and the greater is her functionality.
Only certified signatures fulfil the demands concerning electronic data just as the handwritten
signature demands concerning data in paper form. They are admitted in court as an evidence. 

The cryptographic algorithms admitted for certified electronic signatures are approved and
published by the federal network agency. under www.bundesnetzagentur.de you find a list of all
accredited Certification Service Provider (trust centres). There are also listed the products
admitted for a certified electronic signature.

The requirements for a certified signature are given when:

· this can be associated exclusively to the signatory who admits unequivocal identification of the
signatory

· with means is created which only the signatory controls
· makes every additional update of the signed data evident
· is based on a certified certificate
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A certified certificate can only be issued by an accredited Certification Service Provider.
Particularly strict demands concerning the security of the key creation and the organisation of the
trust centre are valid. The observance of the legal instructions through the trust centre is in
Germany also controlled by the federal network agency.

Public Key procedures

Digital signatures are based on asymmetrical Crypto systems and use a key pair which passes
signature key of a private (confidential one) and public (not confidential).

The data which were encoded with one key can be opened again only with the other.

In order to sign the private key is used. The key is on the chip of the card and cannot be read out.
The data to be processed are loaded on the chip, are encrypted or decrypted there and transmitted
again back to the computer. 

To use the private key, the right PIN which guarantees additional security is required. The
signature can be only from the card owner, because only he is in possession of card and PIN.

The public key is integrated into a certificate and is available for everyone. This can also be
retrieved by directory services via LDAP or HTTP. Of course he can also be dispatched by e-mail.

To guarantee that the certificate and therefore the key was not faked, every certificate is signed by
the publisher. Therefore checks up to themselves whether the certificate of a trustworthy place
was published.

While checking the signature the public key of the receiver is used. The encrypted Hash value of
the publisher is decrypted and compared to the Hash value of the document. If both values agree
the document was not modified.

While signing a file a Hash value which is comparable with a fingerprint is formed. Two different
documents can never have the same Hash value. The Hash value is encrypted under use of a key
with a length of at least 1024 bits (depending on the used card) after the procedure RSA .

The encryption of the Hash value takes place on the card with electronic chip processor which can
process smaller data volumes. Thus it is made sure that the private key does not leave the card.
The encoded Hash value is sent back again to the computer and is seated in the document to be
signed. Before the document could be signed the private key must be released by the right PIN
(Personal Identification Number).
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6. Language.ini

Aloaha Translation/Localisation Engine
Recent Builds of Aloaha localise/translate used strings fully automatic. String Tables are saved as
ini files to allow the user to change strings himself or to localise into a new language without having
to touch the Aloaha Code.

Translation Mechanism
· When Aloaha starts it looks for the language settings in language.ini. Should this file not exist,

the program asks the following paths of the Windows registration
          o HKCU\Software\Aloaha\language
          o HKLM\Software\Aloaha\language
          o The Operating System LanguageID

· Based on the LanguageID Aloaha will ask UserLanguage_<ID>.ini for the string

translation. If that file does not contain the correct translation Aloaha will ask 
Language_<ID>.ini

· The file Language_<ID>.ini will be overwritten by every setup/upgrade. In case a user

wants to modify strings it is suggested to use UserLanguage_<ID>.ini

 

Language.ini
Section [Mapping] instructs to map one language to another. For example 410=409 would mean to
use english (409) on italian (410) systems

Section [languageID] defines which ini files to use for the current mapping.

Translation Files
First Aloaha will ask UserLanguage_<ID> for the translation. If no translation is found it will

ask Language_<ID> for the translation.

If a user wants to change strings it is advised to do the changes in UserLanguage_<ID>.
ini since Language_<ID>.ini will be overwritten with every setup/upgrade.

It is also possible to set registry key HKLM\Software\Aloaha\pdf\WriteMissing
to 1. In that case Aloaha will log all Translation Problems to MissedLanguage_<ID>.ini.

This is very usefull to find the strings to be translated for the new language/localisation.
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7. Tips and Tricks

Sealing Form Fields
Sometimes you must make sure that a PDF document cannot be edited any more. To seal a
document, click with the right mouse button on the PDF document and select the command "Seal".

PDF document sign digitally
Aloaha is able to apply a digital signature to every PDF document or PDF form. It is not necessary
that the document has a special signature field. To sign the PDF document, draw up a field. As
soon as you click with right mouse button in the field, you can sign the document.

To furnish PDF documents with comments
It is possible to drag a field with the mouse in a deliberate position. You can select the command
"Add text field" from the menu. This function adds a text field to your PDF document.

Edit Form Field Properties
You change the properties of the field with a double click on a form field. It is possible to change
position, size, font etc. of the selected field.

Load / Save Documents from / to a Microsoft Sharepoint Server
Aloaha supports direct "loading from" and "saving to" sharepoint. To load a document of the MS
SP, enter the URL.

To allow saving a loaded file back to the MS SP, it is necessary to launch the PDF Signator.

Wenn Sie eine Datei mit der Befehlszeile laden: PDFSignator http://yourserver.tld/pdfdocument.pdf
sind Sie in der Lage, die Datei durch "Speichern" zurück zur Bibliothek zu speichern.
If you load a file with the command line: PDFSignator http://yourserver.tld/
pdfdocument.pdf you are able to save the file by "saving" back to the library.

Moreover the input in the dialog box "Open" is necessary .
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8. FAQ

· Why do I need a PDF Saver/Signator?
Free PDF Reader software is not able to save form data to disk. That means that as soon you
close the reader all data entered into the PDF form is lost. The Aloaha PDF Saver/Signator allows
you to save the PDF INCLUSIVE the form data to disk.

· How can I configure Windows to use the Saver/Signator as default PDF Handler?
Right click on a PDF Document and choose open with, choose program.
In the upcoming dialog please browse to the PDFSaver.exe / PDFSignator.exe and

enable the checkbox to always use the Saver/Signator to open PDF Documents.

· Can I make the Aloaha PDF Saver/Signator the default handler for PDF Files?
Sure, just make sure to use open with when you right click on a PDF File and choose the Aloaha
PDFSaver.exe/PDFSignator.exe for the first time.

· What is the difference between Adobe and Aloaha Mode?
In Aloaha Mode there is NO Adobe PDF Reader required!

· How can I create a form field?
1. Check if HKEY_LOCAL_MACHINE\SOFTWARE\Aloaha\PDFSaver\edit has

value 1
2. Make sure to be in Aloaha Mode in the PDF Saver
3. Draw a selection box while keeping the left mouse button pressed
4. Right Click into the box and choose Edit > Add Text Field

· What is the difference between Saver and Signator?
The Saver focusses on PDF Forms and the Signator on digital signatures.

· How can I load/save documents to/from a sharepoint library?
Aloaha supports loading and saving directly to/from sharepoint. To load a document from
sharepoint just type in the URL into the file open dialog.

To be able to save a loaded file directly back to the sharepoint library it is required to start the PDF
Saver with a command line argument. The reason is that if a URL is typed in into a windows open/
save dialog windows will remap that URL to a local file in the temp directory.

For example if you load a file with the commandline: PDFSaver http://yourserver.
tld/pdfdocument.pdf you are able to save it back to the library with just pressing the

save button.
It is also possible just to choose "upload to" in the menu.

· Is it possible to define the contact information of the signature?
Yes, just set it in HKCU\Software\Aloaha\pdf\signer or
HKLM\Software\Aloaha\signer.

· Is it possible to define the location information of the signature?
Yes, just set it in HKCU\Software\Aloaha\pdf\location or HKLM\Software\
Aloaha\location.

· How do I create a new textbox?
You need to make sure that HKLM\Software\Aloaha\pdfsaver\edit is set to 1.

Then you can just draw a selection box with the left mouse button pressed. If you now right click
into that selection box you can choose to add a text box.

· How do I change the default font of new text boxes?
Create a DWORD Value HKLM\Software\Aloaha\pdfsaver\FFcolor. The value can

be between 0 and FFFFFF.

· Is it possible to remote control the Signator?
Yes, please have a look at http://www.aloaha.com/software-development/
interactive-signatures.php
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